CVE-2018-11574

NameCVE-2018-11574
DescriptionImproper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the `refuse-app` option are unaffected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ppp (PTS)jessie2.4.6-3.1fixed
stretch2.4.7-1+4fixed
bullseye, sid, buster2.4.7-2+4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pppsource(unstable)2.4.7-2+3
pppsourcejessie(not affected)
pppsourcestretch(not affected)
pppsourcewheezy(not affected)

Notes

[stretch] - ppp <not-affected> (Vulnerable code introduced later)
[jessie] - ppp <not-affected> (Vulnerable code introduced later)
[wheezy] - ppp <not-affected> (Vulnerable code introduced later)
http://www.openwall.com/lists/oss-security/2018/06/11/1
https://www.nikhef.nl/~janjust/ppp/ppp-2.4.7-eaptls-mppe-1.101.patch

Search for package or bug name: Reporting problems