CVE-2018-11805

NameCVE-2018-11805
DescriptionIn Apache SpamAssassin before 3.4.3, nefarious CF files can be configured to run system commands without any output or errors. With this, exploits can be injected in a number of scenarios. In addition to upgrading to SA 3.4.3, we recommend that users should only use update channels or 3rd party .cf files from trusted places.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2037-1, DSA-4584-1
NVD severityhigh
Debian Bugs946652

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spamassassin (PTS)jessie3.4.0-6vulnerable
jessie (security)3.4.2-0+deb8u2fixed
stretch3.4.2-1~deb9u1vulnerable
stretch (security)3.4.2-1~deb9u2fixed
buster3.4.2-1vulnerable
buster (security)3.4.2-1+deb10u1fixed
bullseye, sid3.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spamassassinsource(unstable)3.4.3~rc6-1946652
spamassassinsourcebuster3.4.2-1+deb10u1DSA-4584-1
spamassassinsourcejessie3.4.2-0+deb8u2DLA-2037-1
spamassassinsourcestretch3.4.2-1~deb9u2DSA-4584-1

Notes

https://www.openwall.com/lists/oss-security/2019/12/12/1
https://markmail.org/message/pyp425yrulfxyhrn
https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7648 (not public)

Search for package or bug name: Reporting problems