CVE-2018-12127

NameCVE-2018-12127
DescriptionMLPDS Microarchitectural Load Port Data Sampling
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1787-1, DLA-1789-1, DSA-4444-1, DSA-4447-1
Debian Bugs929129

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
intel-microcode (PTS)jessie/non-free3.20180425.1~deb8u1vulnerable
stretch/non-free3.20180807a.2~deb9u1vulnerable
buster/non-free, sid/non-free3.20190514.1fixed
jessie/non-free (security)3.20190514.1~deb8u1fixed
stretch/non-free (security)3.20190514.1~deb9u1fixed
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.64-2vulnerable
stretch4.9.168-1vulnerable
stretch (security)4.9.168-1+deb9u2fixed
buster, sid4.19.37-3fixed
linux-4.9 (PTS)jessie (security)4.9.168-1+deb9u2~deb8u1fixed
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts4-0+deb8u1vulnerable
stretch (security), stretch4.8.5+shim4.10.2+xsa282-1+deb9u11vulnerable
buster, sid4.11.1+26-g87f51bf366-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
intel-microcodesource(unstable)3.20190514.1
intel-microcodesourcejessie3.20190514.1~deb8u1DLA-1789-1
intel-microcodesourcestretch3.20190514.1~deb9u1DSA-4447-1
linuxsource(unstable)4.19.37-2
linuxsourcestretch4.9.168-1+deb9u2DSA-4444-1
linux-4.9sourcejessie4.9.168-1+deb9u2~deb8u1DLA-1787-1
xensource(unstable)(unfixed)929129

Notes

https://git.kernel.org/linus/fa4bff165070dc40a3de35b78e4f8da8e8d85ec5
https://software.intel.com/security-software-guidance/software-guidance/microarchitectural-data-sampling
https://xenbits.xen.org/xsa/advisory-297.html
libvirt support for md-clear CPUID bit:
https://libvirt.org/git/?p=libvirt.git;a=commit;h=538d873571d7a682852dc1d70e5f4478f4d64e85
qemu and libvirt need updates to passthrough md-clear, see #929067 for qemu adnd #929154 for libvirt

Search for package or bug name: Reporting problems