DescriptionAn issue was discovered in in pass in Simple Password Store 1.7.x before 1.7.2. The signature verification routine parses the output of GnuPG with an incomplete regular expression, which allows remote attackers to spoof file signatures on configuration files and extension scripts. Modifying the configuration file allows the attacker to inject additional encryption keys under their control, thereby disclosing passwords to the attacker. Modifying the extension scripts allows the attacker arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs901574

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
password-store (PTS)buster, bullseye1.7.3-2fixed
sid, trixie, bookworm1.7.4-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
password-storesourcejessie(not affected)
password-storesourcestretch(not affected)


[stretch] - password-store <not-affected> (Signature verification support added in 1.7)
[jessie] - password-store <not-affected> (Signature verification support added in 1.7)
Introduced in:
Fixed by:

Search for package or bug name: Reporting problems