CVE-2018-12383

NameCVE-2018-12383
DescriptionIf a user saved passwords before Firefox 58 and then later set a master password, an unencrypted copy of these passwords is still accessible. This is because the older stored password file was not deleted when the data was copied to a new format starting in Firefox 58. The new master password is added only on the new file. This could allow the exposure of stored password data outside of user expectations. This vulnerability affects Firefox < 62, Firefox ESR < 60.2.1, and Thunderbird < 60.2.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1575-1, DSA-4304-1, DSA-4327-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid63.0.3-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)60.3.0esr-1~deb8u1fixed
stretch (security), stretch60.3.0esr-1~deb9u1fixed
buster60.3.0esr-1fixed
sid60.3.0esr-3fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:60.3.0-1~deb8u1fixed
stretch1:60.2.1-2~deb9u1fixed
stretch (security)1:60.3.0-1~deb9u1fixed
buster, sid1:60.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)62.0-1low
firefox-esrsource(unstable)60.2.1esr-1low
firefox-esrsourcestretch60.2.1esr-1~deb9u1lowDSA-4304-1
thunderbirdsource(unstable)1:60.2.1-1low
thunderbirdsourcejessie1:60.3.0-1~deb8u1lowDLA-1575-1
thunderbirdsourcestretch1:60.2.1-2~deb9u1lowDSA-4327-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-20/#CVE-2018-12383
https://www.mozilla.org/en-US/security/advisories/mfsa2018-23/#CVE-2018-12383
https://www.mozilla.org/en-US/security/advisories/mfsa2018-25/#CVE-2018-12383

Search for package or bug name: Reporting problems