CVE-2018-12503

NameCVE-2018-12503
Descriptiontinyexr 0.9.5 has a heap-based buffer over-read in LoadEXRImageFromMemory in tinyexr.h.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tinyexr (PTS)bullseye1.0.0+dfsg-1fixed
bookworm1.0.1+dfsg-2fixed
sid1.0.1+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tinyexrsource(unstable)(not affected)

Notes

- tinyexr <not-affected> (Fixed before initial upload to Debian)
https://github.com/syoyo/tinyexr/issues/81
https://github.com/ChijinZ/security_advisories/tree/master/tinyexr_65f9859#duplicated-cve-2018-12503-heap-buffer-overflow-in-function-tinyexrloadexrimagefromfile-tinyexrh11593

Search for package or bug name: Reporting problems