Information on source package tinyexr

Available versions

ReleaseVersion
bullseye1.0.0+dfsg-1
bookworm1.0.1+dfsg-4
sid1.0.1+dfsg-4

Open issues

BugbullseyebookwormsidDescription
CVE-2022-38529vulnerable (no DSA)fixedfixedtinyexr commit 0647fb3 was discovered to contain a heap-buffer overflo ...
CVE-2022-34300vulnerable (no DSA)fixedfixedIn tinyexr 1.0.1, there is a heap-based buffer over-read in tinyexr::D ...

Open unimportant issues

BugbullseyebookwormsidDescription
CVE-2018-12687vulnerablevulnerablevulnerabletinyexr 0.9.5 has an assertion failure in DecodePixelData in tinyexr.h ...

Resolved issues

BugDescription
CVE-2020-19490tinyexr 0.9.5 has a integer overflow over-write in tinyexr::DecodePixe ...
CVE-2020-18430tinyexr 0.9.5 was discovered to contain an array index error in the ti ...
CVE-2020-18428tinyexr commit 0.9.5 was discovered to contain an array index error in ...
CVE-2018-20652An attempted excessive memory allocation was discovered in the functio ...
CVE-2018-12688tinyexr 0.9.5 has a segmentation fault in the wav2Decode function. ...
CVE-2018-12504tinyexr 0.9.5 has an assertion failure in ComputeChannelLayout in tiny ...
CVE-2018-12503tinyexr 0.9.5 has a heap-based buffer over-read in LoadEXRImageFromMem ...
CVE-2018-12093tinyexr 0.9.5 has a memory leak in ParseEXRHeaderFromMemory in tinyexr ...
CVE-2018-12092tinyexr 0.9.5 has a heap-based buffer over-read in tinyexr::DecodePixe ...
CVE-2018-12064tinyexr 0.9.5 has a heap-based buffer over-read via tinyexr::ReadChann ...

Search for package or bug name: Reporting problems