CVE-2018-12538

NameCVE-2018-12538
DescriptionIn Eclipse Jetty versions 9.4.0 through 9.4.8, when using the optional Jetty provided FileSessionDataStore for persistent storage of HttpSession details, it is possible for a malicious user to access/hijack other HttpSessions and even delete unmatched HttpSessions present in the FileSystem's storage for the FileSessionDataStore.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1fixed
stretch (security)9.2.30-0+deb9u2fixed
buster, buster (security)9.4.16-0+deb10u1fixed
bookworm, bullseye9.4.39-3fixed
sid9.4.44-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysource(unstable)(not affected)
jetty8source(unstable)(not affected)
jetty9source(unstable)(not affected)

Notes

- jetty9 <not-affected> (Only affects 9.4.x)
- jetty8 <not-affected> (Only affects 9.4.x)
- jetty <not-affected> (Only affects 9.4.x)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=536018

Search for package or bug name: Reporting problems