CVE-2018-12563

NameCVE-2018-12563
DescriptionAn issue was discovered in Linaro LAVA before 2018.5.post1. Because of support for file: URLs, a user can force lava-server-gunicorn to download any file from the filesystem if it's readable by lavaserver and valid yaml.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lava (PTS)buster, sid2018.11-1fixed
lava-server (PTS)jessie2014.09.1-1fixed
jessie (security)2014.09.1-1+deb8u1fixed
stretch (security), stretch2016.12-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lavasource(unstable)2018.5.post1-1medium
lava-serversource(unstable)(unfixed)medium
lava-serversourcejessie(not affected)
lava-serversourcestretch(not affected)

Notes

[stretch] - lava-server <not-affected> (Vulnerable code introduced in 2017.6)
[jessie] - lava-server <not-affected> (vulnerable code not present)
https://git.linaro.org/lava/lava.git/commit/?id=e24ec39599bc07562ad8bc2a581144b8448cb214

Search for package or bug name: Reporting problems