CVE-2018-12617

NameCVE-2018-12617
Descriptionqmp_guest_file_read in qga/commands-posix.c and qga/commands-win32.c in qemu-ga (aka QEMU Guest Agent) in QEMU 2.12.50 has an integer overflow causing a g_malloc0() call to trigger a segmentation fault when trying to allocate a large memory chunk. The vulnerability can be exploited by sending a crafted QMP command (including guest-file-read with a large count value) to the agent via the listening socket.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs902725

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u7vulnerable
stretch (security), stretch1:2.8+dfsg-6+deb9u4vulnerable
buster, sid1:2.12+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)low902725

Notes

[stretch] - qemu <postponed> (Minor issue, wait until more severe issues are around)
[jessie] - qemu <postponed> (Minor issue, wait until more severe issues are around)
https://gist.github.com/fakhrizulkifli/c7740d28efa07dafee66d4da5d857ef6
https://lists.gnu.org/archive/html/qemu-devel/2018-06/msg03385.html
Fixed by: https://git.qemu.org/?p=qemu.git;a=commit;h=141b197408ab398c4f474ac1a728ab316e921f2b

Search for package or bug name: Reporting problems