CVE-2018-1285

NameCVE-2018-1285
DescriptionApache log4net versions before 2.0.10 do not disable XML external entities when parsing log4net configuration files. This allows for XXE-based attacks in applications that accept attacker-controlled log4net configuration files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2211-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
log4net (PTS)bullseye, buster, stretch, sid1.2.10+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
log4netsourcejessie1.2.10+dfsg-6+deb8u1DLA-2211-1
log4netsource(unstable)(unfixed)low

Notes

[buster] - log4net <no-dsa> (Minor issue)
[stretch] - log4net <no-dsa> (Minor issue; requires application to accept arbitrary configuration files)
https://issues.apache.org/jira/browse/LOG4NET-575
https://github.com/apache/logging-log4net/commit/d0b4b0157d4af36b23c24a23739c47925c3bd8d7

Search for package or bug name: Reporting problems