CVE-2018-13346

NameCVE-2018-13346
DescriptionThe mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1414-1, DLA-2293-1
NVD severitymedium
Debian Bugs901050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)stretch4.0-1+deb9u1vulnerable
stretch (security)4.0-1+deb9u2fixed
buster4.8.2-1+deb10u1fixed
bookworm, bullseye5.6.1-4fixed
sid5.9-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsourcejessie3.1.2-2+deb8u5DLA-1414-1
mercurialsourcestretch4.0-1+deb9u2DLA-2293-1
mercurialsource(unstable)4.6.1-1901050

Notes

https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.6.1_.282018-06-06.29
https://www.mercurial-scm.org/repo/hg/rev/faa924469635

Search for package or bug name: Reporting problems