CVE-2018-13797

NameCVE-2018-13797
DescriptionThe macaddress module before 0.2.9 for Node.js is prone to an arbitrary command injection flaw, due to allowing unsanitized input to an exec (rather than execFile) call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-macaddress (PTS)buster0.2.9-2fixed
bullseye, sid0.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-macaddresssource(unstable)0.2.9-1unimportant

Notes

https://github.com/scravy/node-macaddress/pull/20
nodejs not covered by security support

Search for package or bug name: Reporting problems