CVE-2018-14036

NameCVE-2018-14036
DescriptionDirectory Traversal with ../ sequences occurs in AccountsService before 0.6.50 because of an insufficient path check in user_change_icon_file_authorized_cb() in user.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs903828

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
accountsservice (PTS)jessie0.6.37-3vulnerable
stretch0.6.43-1vulnerable
buster, sid0.6.45-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
accountsservicesource(unstable)(unfixed)low903828

Notes

[stretch] - accountsservice <no-dsa> (Minor issue)
[jessie] - accountsservice <ignored> (Minor issue)
http://www.openwall.com/lists/oss-security/2018/07/02/2
https://bugs.freedesktop.org/show_bug.cgi?id=107085
https://cgit.freedesktop.org/accountsservice/commit/?id=f9abd359f71a5bce421b9ae23432f539a067847a

Search for package or bug name: Reporting problems