CVE-2018-14447

NameCVE-2018-14447
Descriptiontrim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1470-1
NVD severitymedium (attack range: remote)
Debian Bugs904159

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
confuse (PTS)jessie2.7-5vulnerable
jessie (security)2.7-5+deb8u1fixed
stretch3.0+dfsg-2+deb9u1fixed
buster, sid3.2.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
confusesource(unstable)3.2.1+dfsg-5medium904159
confusesourcejessie2.7-5+deb8u1mediumDLA-1470-1
confusesourcestretch3.0+dfsg-2+deb9u1medium

Notes

https://github.com/martinh/libconfuse/issues/109

Search for package or bug name: Reporting problems