CVE-2018-14600

NameCVE-2018-14600
DescriptionAn issue was discovered in libX11 through 1.6.5. The function XListExtensions in ListExt.c interprets a variable as signed instead of unsigned, resulting in an out-of-bounds write (of up to 128 bytes), leading to DoS or remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1482-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libx11 (PTS)buster2:1.6.7-1+deb10u2fixed
buster (security)2:1.6.7-1+deb10u4fixed
bullseye, bullseye (security)2:1.7.2-1+deb11u2fixed
bookworm, bookworm (security)2:1.8.4-2+deb12u2fixed
sid, trixie2:1.8.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libx11sourcejessie2:1.6.2-3+deb8u2DLA-1482-1
libx11sourcestretch2:1.6.4-3+deb9u1
libx11source(unstable)2:1.6.6-1low

Notes

[wheezy] - libx11 <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/xorg/lib/libx11/commit/dbf72805fd9d7b1846fe9a11b46f3994bfc27fea

Search for package or bug name: Reporting problems