CVE-2018-14614

NameCVE-2018-14614
DescriptionAn issue was discovered in the Linux kernel through 4.17.10. There is an out-of-bounds access in __remove_dirty_segment() in fs/f2fs/segment.c when mounting an f2fs image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1715-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.74-1vulnerable
stretch4.9.189-3fixed
stretch (security)4.9.189-3+deb9u1fixed
buster4.19.67-2fixed
buster (security)4.19.67-2+deb10u1fixed
bullseye, sid5.2.17-1fixed
linux-4.9 (PTS)jessie (security)4.9.189-3+deb9u1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.19.9-1high
linuxsourcestretch4.9.144-1high
linux-4.9sourcejessie4.9.144-3.1~deb8u1highDLA-1715-1

Notes

[jessie] - linux <ignored> (Hard to backport and low priority outside of Android)
https://bugzilla.kernel.org/show_bug.cgi?id=200419

Search for package or bug name: Reporting problems