CVE-2018-15857

NameCVE-2018-15857
DescriptionAn invalid free in ExprAppendMultiKeysymList in xkbcomp/ast-build.c in xkbcommon before 0.8.1 could be used by local attackers to crash xkbcommon keymap parsers or possibly have unspecified other impact by supplying a crafted keymap file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs907302

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxkbcommon (PTS)stretch0.7.1-2~deb9u1vulnerable
buster0.8.2-1fixed
bullseye, sid0.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxkbcommonsource(unstable)0.8.2-1low907302

Notes

[stretch] - libxkbcommon <ignored> (Minor issue)
[jessie] - libxkbcommon <no-dsa> (Minor issue)
https://github.com/xkbcommon/libxkbcommon/commit/c1e5ac16e77a21f87bdf3bc4dea61b037a17dddb
https://lists.freedesktop.org/archives/wayland-devel/2018-August/039232.html

Search for package or bug name: Reporting problems