Information on source package libxkbcommon

Available versions

ReleaseVersion
jessie0.4.3-2
stretch0.7.1-2~deb9u1
buster0.8.2-1
bullseye0.8.4-1
sid0.8.4-1

Open issues

BugjessiestretchbusterbullseyesidDescription
CVE-2018-15864vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in resolve_keysym in xkbcomp/parser.y in ...
CVE-2018-15863vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in ResolveStateAndPredicate in xkbcomp/co ...
CVE-2018-15862vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in LookupModMask in xkbcomp/expr.c in xkb ...
CVE-2018-15861vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in ExprResolveLhs in xkbcomp/expr.c in xk ...
CVE-2018-15859vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage when parsing invalid atoms in ExprResolve ...
CVE-2018-15858vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage when handling invalid aliases in CopyKeyA ...
CVE-2018-15857vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedAn invalid free in ExprAppendMultiKeysymList in xkbcomp/ast-build.c in ...
CVE-2018-15856vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedAn infinite loop when reaching EOL unexpectedly in compose/parser.c (a ...
CVE-2018-15855vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in xkbcommon before 0.8.1 could be used b ...
CVE-2018-15854vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedUnchecked NULL pointer usage in xkbcommon before 0.8.1 could be used b ...
CVE-2018-15853vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedEndless recursion exists in xkbcomp/expr.c in xkbcommon and libxkbcomm ...

Search for package or bug name: Reporting problems