CVE-2018-15861

NameCVE-2018-15861
DescriptionUnchecked NULL pointer usage in ExprResolveLhs in xkbcomp/expr.c in xkbcommon before 0.8.2 could be used by local attackers to crash (NULL pointer dereference) the xkbcommon parser by supplying a crafted keymap file that triggers an xkb_intern_atom failure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs907302

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxkbcommon (PTS)stretch0.7.1-2~deb9u1vulnerable
buster0.8.2-1fixed
bullseye0.10.0-1fixed
sid1.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxkbcommonsource(unstable)0.8.2-1low907302

Notes

[stretch] - libxkbcommon <ignored> (Minor issue)
[jessie] - libxkbcommon <no-dsa> (Minor issue)
https://github.com/xkbcommon/libxkbcommon/commit/38e1766bc6e20108948aec8a0b222a4bad0254e9
https://lists.freedesktop.org/archives/wayland-devel/2018-August/039243.html

Search for package or bug name: Reporting problems