CVE-2018-16382

NameCVE-2018-16382
DescriptionNetwide Assembler (NASM) 2.14rc15 has a buffer over-read in x86/regflags.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs907866

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nasm (PTS)jessie2.11.05-1vulnerable
stretch2.12.01-1vulnerable
buster, sid2.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nasmsource(unstable)2.14-1unimportant907866

Notes

https://bugzilla.nasm.us/show_bug.cgi?id=3392503
Duplicate of/relate to https://bugzilla.nasm.us/show_bug.cgi?id=3392447
https://github.com/netwide-assembler/nasm/commit/3c755dac88039b718d52ef56e8f74b5f65f3b55b
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems