CVE-2018-16831

NameCVE-2018-16831
DescriptionSmarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs908698

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)jessie (security), jessie3.1.21-1+deb8u2vulnerable
stretch (security), stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1vulnerable
buster, sid3.1.33+20180830.1.3a78a21f+selfpack1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smarty3source(unstable)3.1.33+20180830.1.3a78a21f+selfpack1-1908698

Notes

https://github.com/smarty-php/smarty/issues/486
CVE is about the include tag as an attack vector.

Search for package or bug name: Reporting problems