CVE-2018-16837

NameCVE-2018-16837
DescriptionAnsible "User" module leaks any data which is passed on as a parameter to ssh-keygen. This could lean in undesirable situations such as passphrases credentials passed as a parameter for the ssh-keygen executable. Showing those credentials in clear text form for every user which have access just to the process list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1576-1
Debian Bugs912297

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)jessie1.7.2+dfsg-2vulnerable
jessie (security)1.7.2+dfsg-2+deb8u1fixed
stretch2.2.1.0-2vulnerable
buster2.7.1+dfsg-1fixed
sid2.7.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)2.7.1+dfsg-1912297
ansiblesourcejessie1.7.2+dfsg-2+deb8u1DLA-1576-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1640642
https://github.com/ansible/ansible/pull/47436

Search for package or bug name: Reporting problems