CVE-2018-16843

NameCVE-2018-16843
Descriptionnginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4335-1
Debian Bugs913090

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)jessie1.6.2-5+deb8u5fixed
jessie (security)1.6.2-5+deb8u6fixed
stretch1.10.3-1+deb9u1vulnerable
stretch (security)1.10.3-1+deb9u2fixed
buster, sid1.14.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)1.14.1-1913090
nginxsourcejessie(not affected)
nginxsourcestretch1.10.3-1+deb9u2DSA-4335-1

Notes

[jessie] - nginx <not-affected> (HTTP 2.0 support added later)
http://mailman.nginx.org/pipermail/nginx-announce/2018/000220.html
http://hg.nginx.org/nginx/rev/d4448892a294
Fixed in 1.15.6, 1.14.1.

Search for package or bug name: Reporting problems