CVE-2018-16858

NameCVE-2018-16858
DescriptionIt was found that libreoffice before versions 6.0.7 and 6.1.3 was vulnerable to a directory traversal attack which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document, which when opened by LibreOffice, would execute a Python method from a script in any arbitrary file system location, specified relative to the LibreOffice install location.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1669-1, DSA-4381-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)jessie1:4.3.3-2+deb8u11vulnerable
jessie (security)1:4.3.3-2+deb8u12fixed
stretch1:5.2.7-1+deb9u7fixed
stretch (security)1:5.2.7-1+deb9u10fixed
buster1:6.1.5-3fixed
buster (security)1:6.1.5-3+deb10u3fixed
bullseye, sid1:6.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:6.1.3-1high
libreofficesourcejessie1:4.3.3-2+deb8u12highDLA-1669-1
libreofficesourcestretch1:5.2.7-1+deb9u5highDSA-4381-1

Notes

https://insert-script.blogspot.com/2019/02/libreoffice-cve-2018-16858-remote-code.html

Search for package or bug name: Reporting problems