CVE-2018-16876

NameCVE-2018-16876
Descriptionansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4396-1
NVD severitymedium (attack range: remote)
Debian Bugs916102

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)jessie1.7.2+dfsg-2fixed
jessie (security)1.7.2+dfsg-2+deb8u1fixed
stretch (security), stretch2.2.1.0-2+deb9u1fixed
buster2.7.7+dfsg-1fixed
sid2.7.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)2.7.6+dfsg-1medium916102
ansiblesourcejessie(not affected)
ansiblesourcestretch2.2.1.0-2+deb9u1mediumDSA-4396-1

Notes

[jessie] - ansible <not-affected> (Vulnerable code not present)
https://github.com/ansible/ansible/pull/49569
https://github.com/ansible/ansible/commit/4c6d714aefb05366cb329e139214c89ebb364899

Search for package or bug name: Reporting problems