CVE-2018-16947

NameCVE-2018-16947
DescriptionAn issue was discovered in OpenAFS before 1.6.23 and 1.8.x before 1.8.2. The backup tape controller (butc) process accepts incoming RPCs but does not require (or allow for) authentication of those RPCs. Handling those RPCs results in operations being performed with administrator credentials, including dumping/restoring volume contents and manipulating the backup database. For example, an unauthenticated attacker can replace any volume's content with arbitrary data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1513-1, DSA-4302-1
NVD severityhigh (attack range: remote)
Debian Bugs908616

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)jessie1.6.9-2+deb8u7vulnerable
jessie (security)1.6.9-2+deb8u8fixed
stretch (security), stretch1.6.20-2+deb9u2fixed
buster, sid1.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.8.2-1high908616
openafssourcejessie1.6.9-2+deb8u8highDLA-1513-1
openafssourcestretch1.6.20-2+deb9u2highDSA-4302-1

Notes

http://openafs.org/pages/security/OPENAFS-SA-2018-001.txt

Search for package or bug name: Reporting problems