CVE-2018-17076

NameCVE-2018-17076
DescriptionGPP through 2.25 will try to use more memory space than is available on the stack, leading to a segmentation fault or possibly unspecified other impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs908939

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpp (PTS)jessie, stretch2.24-3vulnerable
buster, sid2.25-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gppsource(unstable)(unfixed)medium908939

Notes

[stretch] - gpp <no-dsa> (Minor issue)
[jessie] - gpp <no-dsa> (Minor issue)
https://github.com/logological/gpp/issues/26

Search for package or bug name: Reporting problems