CVE-2018-17076

NameCVE-2018-17076
DescriptionGPP through 2.25 will try to use more memory space than is available on the stack, leading to a segmentation fault or possibly unspecified other impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs908939

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpp (PTS)stretch2.24-3vulnerable
buster2.25-1vulnerable
bullseye, sid2.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gppsource(unstable)2.26-1unimportant908939

Notes

https://github.com/logological/gpp/issues/26
https://github.com/logological/gpp/commit/329aa63a70d32d1e2ae529130a792e0c6ae4ce79
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems