CVE-2018-17144

NameCVE-2018-17144
DescriptionBitcoin Core 0.14.x before 0.14.3, 0.15.x before 0.15.2, and 0.16.x before 0.16.3 and Bitcoin Knots 0.14.x through 0.16.x before 0.16.3 allow a remote denial of service (application crash) exploitable by miners via duplicate input. An attacker can make bitcoind or Bitcoin-Qt crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dogecoin (PTS)buster1.10.0-7.1vulnerable
sid1.14.7-1fixed
litecoin (PTS)bullseye0.18.1-1.1fixed
bookworm0.21.2.1-1fixed
sid, trixie0.21.2.2-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bitcoinsource(unstable)0.16.3~dfsg-1
dogecoinsource(unstable)1.14.0-1
litecoinsource(unstable)0.16.3-1

Notes

https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures#CVE-2018-17144
https://github.com/dogecoin/dogecoin/pull/1526
https://github.com/dogecoin/dogecoin/commit/52965fbaef4b8ff310e01273817fb027389d3f80 (v1.14-alpha-4)

Search for package or bug name: Reporting problems