CVE-2018-17182

NameCVE-2018-17182
DescriptionAn issue was discovered in the Linux kernel through 4.18.8. The vmacache_flush_all function in mm/vmacache.c mishandles sequence number overflows. An attacker can trigger a use-after-free (and possibly gain privileges) via certain thread creation, map, unmap, invalidation, and dereference operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1529-1, DLA-1531-1, DSA-4308-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.59-1fixed
stretch4.9.130-2fixed
stretch (security)4.9.110-3+deb9u6fixed
buster, sid4.18.10-2fixed
linux-4.9 (PTS)jessie (security)4.9.110-3+deb9u5~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.18.10-1
linuxsourcejessie3.16.59-1DLA-1529-1
linuxsourcestretch4.9.110-3+deb9u5DSA-4308-1
linux-4.9sourcejessie4.9.110-3+deb9u5~deb8u1DLA-1531-1

Notes

https://git.kernel.org/linus/7a9cdebdcc17e426fb5287e4a82db1dfe86339b2
https://googleprojectzero.blogspot.com/2018/09/a-cache-invalidation-bug-in-linux.html

Search for package or bug name: Reporting problems