CVE-2018-17183

NameCVE-2018-17183
DescriptionArtifex Ghostscript before 9.25 allowed a user-writable error exception table, which could be used by remote attackers able to supply crafted PostScript to potentially overwrite or replace error handlers to inject code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1527-1, DSA-4294-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.06~dfsg-2+deb8u12fixed
stretch9.20~dfsg-3.2+deb9u5fixed
stretch (security)9.26~dfsg-0+deb9u1fixed
buster, sid9.26~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.25~dfsg-1medium
ghostscriptsourcejessie9.06~dfsg-2+deb8u9mediumDLA-1527-1
ghostscriptsourcestretch9.20~dfsg-3.2+deb9u5mediumDSA-4294-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=699708
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=fb713b3818b52d8a6cf62c951eba2e1795ff9624

Search for package or bug name: Reporting problems