CVE-2018-17191

NameCVE-2018-17191
DescriptionApache NetBeans (incubating) 9.0 NetBeans Proxy Auto-Configuration (PAC) interpretation is vulnerable for remote command execution (RCE). Using the nashorn script engine the environment of the javascript execution for the Proxy Auto-Configuration leaks privileged objects, that can be used to circumvent the execution limits. If a different script engine was used, no execution limits were in place. Both vectors allow remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netbeans (PTS)stretch8.1+dfsg3-2vulnerable
buster, sid10.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netbeanssource(unstable)10.0-1high

Notes

[stretch] - netbeans <ignored> (Nashorn module is not enabled. Javascript support is incomplete)
Fixed upstream in version 10.0
https://www.openwall.com/lists/oss-security/2018/12/30/1

Search for package or bug name: Reporting problems