CVE-2018-17540

NameCVE-2018-17540
DescriptionThe gmp plugin in strongSwan before 5.7.1 has a Buffer Overflow via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1528-1, DSA-4309-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)jessie5.2.1-6+deb8u6vulnerable
jessie (security)5.2.1-6+deb8u8fixed
stretch (security), stretch5.5.1-4+deb9u4fixed
buster, sid5.7.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.7.1-1medium
strongswansourcejessie5.2.1-6+deb8u8mediumDLA-1528-1
strongswansourcestretch5.5.1-4+deb9u4mediumDSA-4309-1

Notes

https://www.strongswan.org/blog/2018/10/01/strongswan-vulnerability-(cve-2018-17540).html

Search for package or bug name: Reporting problems