CVE-2018-18311

NameCVE-2018-18311
DescriptionPerl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1601-1, DSA-4347-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)jessie5.20.2-3+deb8u11vulnerable
jessie (security)5.20.2-3+deb8u12fixed
stretch5.24.1-3+deb9u4vulnerable
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-1fixed
sid5.28.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.28.1-1
perlsourcejessie5.20.2-3+deb8u12DLA-1601-1
perlsourcestretch5.24.1-3+deb9u5DSA-4347-1

Notes

https://rt.perl.org/Ticket/Display.html?id=133204
Introduced by: https://perl5.git.perl.org/perl.git/commitdiff/e658793210bbe632a5e80a876acfcd0984c46b87
maint-5.28: https://perl5.git.perl.org/perl.git/commitdiff/0589f071dc6836de80b24fd798c3336c72ead850

Search for package or bug name: Reporting problems