CVE-2018-18313

NameCVE-2018-18313
DescriptionPerl before 5.26.3 has a buffer over-read via a crafted regular expression that triggers disclosure of sensitive information from process memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4347-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)jessie5.20.2-3+deb8u11fixed
jessie (security)5.20.2-3+deb8u12fixed
stretch5.24.1-3+deb9u4vulnerable
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-1fixed
sid5.28.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.28.0-3
perlsourcejessie(not affected)
perlsourcestretch5.24.1-3+deb9u5DSA-4347-1

Notes

[jessie] - perl <not-affected> (Vulnerable code introduced later)
https://rt.perl.org/Ticket/Display.html?id=133192
maint-5.28: https://perl5.git.perl.org/perl.git/commitdiff/43b2f4ef399e2fd7240b4eeb0658686ad95f8e62

Search for package or bug name: Reporting problems