CVE-2018-18356

NameCVE-2018-18356
DescriptionAn integer overflow in path handling lead to a use after free in Skia in Google Chrome prior to 71.0.3578.80 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1677-1, DLA-1678-1, DSA-4352-1, DSA-4391-1, DSA-4392-1
NVD severitymedium (attack range: remote)
Debian Bugs818180

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)stretch (security)73.0.3683.75-1~deb9u1fixed
buster73.0.3683.75-1fixed
buster (security)76.0.3809.100-1~deb10u1fixed
bullseye, sid76.0.3809.100-1fixed
chromium-browser (PTS)stretch70.0.3538.110-1~deb9u1vulnerable
stretch (security)71.0.3578.80-1~deb9u1fixed
firefox (PTS)sid69.0-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)60.9.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)60.9.0esr-1~deb9u1fixed
buster60.8.0esr-1~deb10u1fixed
buster (security)60.9.0esr-1~deb10u1fixed
bullseye60.8.0esr-1fixed
sid68.1.0esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:60.8.0-1~deb8u1fixed
stretch (security), stretch1:60.8.0-1~deb9u1fixed
buster, buster (security)1:60.8.0-1~deb10u1fixed
bullseye, sid1:60.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsource(unstable)71.0.3578.80-1medium
chromium-browsersourcestretch71.0.3578.80-1~deb9u1mediumDSA-4352-1
firefoxsource(unstable)65.0.1-1medium
firefox-esrsource(unstable)60.5.1esr-1medium
firefox-esrsourcejessie60.5.1esr-1~deb8u1mediumDLA-1677-1
firefox-esrsourcestretch60.5.1esr-1~deb9u1mediumDSA-4391-1
skiaITP818180
thunderbirdsource(unstable)1:60.5.1-1medium
thunderbirdsourcejessie1:60.5.1-1~deb8u1mediumDLA-1678-1
thunderbirdsourcestretch1:60.5.1-1~deb9u1mediumDSA-4392-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-04/#CVE-2018-18356
https://www.mozilla.org/en-US/security/advisories/mfsa2019-05/#CVE-2018-18356
https://www.mozilla.org/en-US/security/advisories/mfsa2019-06/#CVE-2018-18356

Search for package or bug name: Reporting problems