CVE-2018-18385

NameCVE-2018-18385
DescriptionAsciidoctor in versions < 1.5.8 allows remote attackers to cause a denial of service (infinite loop). The loop was caused by the fact that Parser.next_block was not exhausting all the lines in the reader as the while loop expected it would. This was happening because the regular expression that detects any list was not agreeing with the regular expression that detects a specific list type. So the line kept getting pushed back onto the reader, hence causing the loop.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs913892

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asciidoctor (PTS)jessie0.1.4-3vulnerable
stretch1.5.4-2vulnerable
buster, sid1.5.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asciidoctorsource(unstable)1.5.8-1low913892

Notes

[stretch] - asciidoctor <no-dsa> (Minor issue)
[jessie] - asciidoctor <no-dsa> (Minor issue)
https://github.com/asciidoctor/asciidoctor/issues/2888

Search for package or bug name: Reporting problems