CVE-2018-18718

NameCVE-2018-18718
DescriptionAn issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1567-1
NVD severitymedium (attack range: local)
Debian Bugs912290

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gthumb (PTS)jessie3:3.3.1-2vulnerable
jessie (security)3:3.3.1-2.1+deb8u1fixed
stretch3:3.4.4.1-5vulnerable
buster, sid3:3.6.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gthumbsource(unstable)3:3.6.2-2unimportant912290
gthumbsourcejessie3:3.3.1-2.1+deb8u1mediumDLA-1567-1

Notes

https://gitlab.gnome.org/GNOME/gthumb/issues/18
Crash in end user application, no security impact

Search for package or bug name: Reporting problems