CVE-2018-18820

NameCVE-2018-18820
DescriptionA buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1588-1, DSA-4333-1
Debian Bugs912611

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icecast2 (PTS)jessie2.4.0-1.1+deb8u1vulnerable
jessie (security)2.4.0-1.1+deb8u2fixed
stretch2.4.2-1vulnerable
stretch (security)2.4.2-1+deb9u1fixed
buster, sid2.4.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icecast2source(unstable)2.4.4-1912611
icecast2sourcejessie2.4.0-1.1+deb8u2DLA-1588-1
icecast2sourcestretch2.4.2-1+deb9u1DSA-4333-1

Notes

https://www.openwall.com/lists/oss-security/2018/11/01/3
https://gitlab.xiph.org/xiph/icecast-server/issues/2342
Fixed by: https://gitlab.xiph.org/xiph/icecast-server/commit/b21a7283bd1598c5af0bbb250a041ba8198f98f2
Additional issue fixed with https://gitlab.xiph.org/xiph/icecast-server/commit/03ea74c04a5966114c2fe66e4e6892d11a68181e
https://lgtm.com/blog/icecast_snprintf_CVE-2018-18820

Search for package or bug name: Reporting problems