CVE-2018-19486

NameCVE-2018-19486
DescriptionGit before 2.19.2 on Linux and UNIX executes commands from the current working directory (as if '.' were at the end of $PATH) in certain cases involving the run_command() API and run-command.c, because there was a dangerous change from execvp to execv during 2017.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)jessie1:2.1.4-2.1+deb8u6fixed
jessie (security)1:2.1.4-2.1+deb8u7fixed
stretch (security), stretch1:2.11.0-3+deb9u4fixed
buster1:2.19.2-1fixed
sid1:2.20.0~rc2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.19.2-1
gitsourcejessie(not affected)
gitsourcestretch(not affected)

Notes

[stretch] - git <not-affected> (Vulnerable code introduced later)
[jessie] - git <not-affected> (Vulnerable code introduced later)
Fixed by: https://git.kernel.org/pub/scm/git/git.git/commit/?id=321fd82389742398d2924640ce3a61791fd27d60
Introduced by: https://git.kernel.org/pub/scm/git/git.git/commit/?id=e3a434468fecca7c14a6bef32050dfa60534fde6

Search for package or bug name: Reporting problems