CVE-2018-19623

NameCVE-2018-19623
DescriptionIn Wireshark 2.6.0 to 2.6.4 and 2.4.0 to 2.4.10, the LBMPDM dissector could crash. In addition, a remote attacker could write arbitrary data to any memory locations before the packet-scoped memory. This was addressed in epan/dissectors/packet-lbmpdm.c by disallowing certain negative values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1634-1, DSA-4359-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u19fixed
stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye, sid3.0.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.6.5-1
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u16DLA-1634-1
wiresharksourcestretch2.6.5-1~deb9u1DSA-4359-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=15132
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=9c8645ec7b28e4d7193962ecd2a418613bf6a84f
https://www.wireshark.org/security/wnpa-sec-2018-53.html

Search for package or bug name: Reporting problems