CVE-2018-19962

NameCVE-2018-19962
DescriptionAn issue was discovered in Xen through 4.11.x on AMD x86 platforms, possibly allowing guest OS users to gain host OS privileges because small IOMMU mappings are unsafely combined into larger ones.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1949-1, DSA-4369-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts5-0+deb8u1fixed
stretch (security), stretch4.8.5+shim4.10.2+xsa282-1+deb9u11fixed
bullseye, sid, buster4.11.1+92-g6c33308a8d-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.1-1
xensourcejessie4.4.4lts5-0+deb8u1DLA-1949-1
xensourcestretch4.8.5+shim4.10.2+xsa282-1+deb9u11DSA-4369-1

Notes

https://xenbits.xen.org/xsa/advisory-275.txt

Search for package or bug name: Reporting problems