CVE-2018-19966

NameCVE-2018-19966
DescriptionAn issue was discovered in Xen through 4.11.x allowing x86 PV guest OS users to cause a denial of service (host OS crash) or possibly gain host OS privileges because of an interpretation conflict for a union data structure associated with shadow paging. NOTE: this issue exists because of an incorrect fix for CVE-2017-15595.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4369-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts4-0+deb8u1vulnerable
stretch (security), stretch4.8.5+shim4.10.2+xsa282-1+deb9u11fixed
bullseye, sid, buster4.11.1+92-g6c33308a8d-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.1-1high
xensourcestretch4.8.5+shim4.10.2+xsa282-1+deb9u11highDSA-4369-1

Notes

https://xenbits.xen.org/xsa/advisory-280.txt

Search for package or bug name: Reporting problems