CVE-2018-20019

NameCVE-2018-20019
DescriptionLibVNC before commit a83439b9fbe0f03c48eb94ed05729cb016f8b72f contains multiple heap out-of-bound write vulnerabilities in VNC client code that can result remote code execution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1617-1, DSA-4383-1
NVD severityhigh (attack range: remote)
Debian Bugs916941

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)jessie0.9.9+dfsg2-6.1+deb8u3vulnerable
jessie (security)0.9.9+dfsg2-6.1+deb8u5fixed
stretch (security), stretch0.9.11+dfsg-1.3~deb9u1fixed
buster, sid0.9.11+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.11+dfsg-1.2high916941
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u4highDLA-1617-1
libvncserversourcestretch0.9.11+dfsg-1.3~deb9u1highDSA-4383-1

Notes

https://github.com/LibVNC/libvncserver/issues/247
https://github.com/LibVNC/libvncserver/commit/a83439b9fbe0f03c48eb94ed05729cb016f8b72f
https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-029-libvnc-multiple-heap-out-of-bound-vulnerabilities/
When fixing this issue apply the complete set of fixes to not open CVE-2018-20748.
Additional commits:
https://github.com/LibVNC/libvncserver/commit/c5ba3fee85a7ecbbca1df5ffd46d32b92757bc2a
https://github.com/LibVNC/libvncserver/commit/e34bcbb759ca5bef85809967a268fdf214c1ad2c
https://github.com/LibVNC/libvncserver/commit/c2c4b81e6cb3b485fb1ec7ba9e7defeb889f6ba7
https://github.com/LibVNC/libvncserver/commit/a64c3b37af9a6c8f8009d7516874b8d266b42bae

Search for package or bug name: Reporting problems