CVE-2018-20430

NameCVE-2018-20430
DescriptionGNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1616-1, DSA-4361-1
Debian Bugs917214

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)buster1:1.8-2+deb10u1fixed
bullseye1:1.11-2fixed
bookworm, sid1:1.11-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsourcejessie1:1.3-2+deb8u4DLA-1616-1
libextractorsourcestretch1:1.3-4+deb9u3DSA-4361-1
libextractorsource(unstable)1:1.8-2917214

Notes

https://gnunet.org/bugs/view.php?id=5493
https://git.gnunet.org/libextractor.git/commit/?id=b405d707b36e0654900cba78e89f49779efea110

Search for package or bug name: Reporting problems