CVE-2018-20549

NameCVE-2018-20549
DescriptionThere is an illegal WRITE memory access at caca/file.c (function caca_file_read) in libcaca 0.99.beta19.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1631-1
NVD severitymedium
Debian Bugs917807

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcaca (PTS)jessie0.99.beta19-2vulnerable
jessie (security)0.99.beta19-2+deb8u1fixed
stretch0.99.beta19-2.1~deb9u1fixed
bullseye, sid, buster0.99.beta19-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcacasource(unstable)0.99.beta19-2.1low917807
libcacasourcejessie0.99.beta19-2+deb8u1DLA-1631-1
libcacasourcestretch0.99.beta19-2.1~deb9u1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1652628
https://github.com/cacalabs/libcaca/issues/41
Fixed by: https://github.com/cacalabs/libcaca/commit/3e52dabe3e64dc50f4422effe364a1457a8a8592

Search for package or bug name: Reporting problems