CVE-2018-20662

NameCVE-2018-20662
DescriptionIn Poppler 0.72.0, PDFDoc::setup in PDFDoc.cc allows attackers to cause a denial-of-service (application crash caused by Object.h SIGABRT, because of a wrong return value from PDFDoc::setup) by crafting a PDF file in which an xref data structure is mishandled during extractPDFSubtype processing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1706-1
NVD severitymedium (attack range: remote)
Debian Bugs918158

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4vulnerable
jessie (security)0.26.5-2+deb8u10fixed
stretch (security), stretch0.48.0-2+deb9u2vulnerable
buster, sid0.71.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.71.0-4low918158
popplersourcejessie0.26.5-2+deb8u8mediumDLA-1706-1

Notes

[stretch] - poppler <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/poppler/poppler/issues/706
https://gitlab.freedesktop.org/poppler/poppler/commit/7b4e372deeb716eb3fe3a54b31ed41af759224f9

Search for package or bug name: Reporting problems