CVE-2018-20748

NameCVE-2018-20748
DescriptionLibVNC before 0.9.12 contains multiple heap out-of-bounds write vulnerabilities in libvncclient/rfbproto.c. The fix for CVE-2018-20019 was incomplete.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1652-1
NVD severityhigh (attack range: remote)
Debian Bugs920941

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)jessie0.9.9+dfsg2-6.1+deb8u3vulnerable
jessie (security)0.9.9+dfsg2-6.1+deb8u5fixed
stretch (security), stretch0.9.11+dfsg-1.3~deb9u1fixed
bullseye, buster, sid0.9.11+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.11+dfsg-1.3high920941
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u5highDLA-1652-1
libvncserversourcestretch(not affected)

Notes

[stretch] - libvncserver <not-affected> (Incomplete fix for CVE-2018-20019 not applied)
https://github.com/LibVNC/libvncserver/commit/c5ba3fee85a7ecbbca1df5ffd46d32b92757bc2a
https://github.com/LibVNC/libvncserver/commit/e34bcbb759ca5bef85809967a268fdf214c1ad2c
https://github.com/LibVNC/libvncserver/commit/c2c4b81e6cb3b485fb1ec7ba9e7defeb889f6ba7
https://github.com/LibVNC/libvncserver/commit/a64c3b37af9a6c8f8009d7516874b8d266b42bae

Search for package or bug name: Reporting problems