CVE-2018-20749

NameCVE-2018-20749
DescriptionLibVNC before 0.9.12 contains a heap out-of-bounds write vulnerability in libvncserver/rfbserver.c. The fix for CVE-2018-15127 was incomplete.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1652-1, DLA-1979-1
NVD severityhigh
Debian Bugs920941

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
italc (PTS)jessie1:2.0.2+dfsg1-2vulnerable
jessie (security)1:2.0.2+dfsg1-2+deb8u1fixed
stretch1:3.0.3+dfsg1-1vulnerable
libvncserver (PTS)jessie0.9.9+dfsg2-6.1+deb8u3vulnerable
jessie (security)0.9.9+dfsg2-6.1+deb8u6fixed
stretch (security), stretch0.9.11+dfsg-1.3~deb9u1fixed
bullseye, sid, buster0.9.11+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
italcsource(unstable)(unfixed)
italcsourcejessie1:2.0.2+dfsg1-2+deb8u1DLA-1979-1
libvncserversource(unstable)0.9.11+dfsg-1.3920941
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u5DLA-1652-1
libvncserversourcestretch(not affected)

Notes

[stretch] - libvncserver <not-affected> (Incomplete fix for CVE-2018-15127 not applied)
https://github.com/LibVNC/libvncserver/commit/15bb719c03cc70f14c36a843dcb16ed69b405707

Search for package or bug name: Reporting problems