CVE-2018-21247

NameCVE-2018-21247
DescriptionAn issue was discovered in LibVNCServer before 0.9.13. There is an information leak (of uninitialized memory contents) in the libvncclient/rfbproto.c ConnectToRFBRepeater function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1617-1, DSA-4383-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)buster0.9.11+dfsg-1.3+deb10u4fixed
buster (security)0.9.11+dfsg-1.3+deb10u5fixed
bullseye0.9.13+dfsg-2+deb11u1fixed
bookworm, sid0.9.13+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u4DLA-1617-1
libvncserversourcestretch0.9.11+dfsg-1.3~deb9u1DSA-4383-1
libvncserversource(unstable)0.9.11+dfsg-1.2

Notes

https://github.com/LibVNC/libvncserver/issues/253
https://github.com/LibVNC/libvncserver/commit/8b06f835e259652b0ff026898014fc7297ade858

Search for package or bug name: Reporting problems